Proficient Capture Fax Processing Delay

Incident Report for Proficient Health

Resolved

This incident has been resolved.
Posted Sep 22, 2021 - 14:44 EDT

Monitoring

Proficient Capture Super Users,

We are currently experiencing issues that are causing delays in fax processing.

We are diligently working with our upstream carriers to identify and resolve these issues, and will provide an update once the cause has been identified or resolved.

Sincerely,

Proficient Health Support
Posted Sep 21, 2021 - 13:03 EDT
This incident affected: Fax Processing.