Proficient Capture Performance Issues

Incident Report for Proficient Health

Resolved

This incident has been resolved.
Posted May 27, 2024 - 14:45 EDT

Investigating

Proficient Super Users,

We are current experiencing performance issues that are affecting workflows.

We are diligently working to identify and resolve these issues, and will provide an update once the cause has been identified or resolved.

Sincerely,

Proficient Health Support
Posted May 27, 2024 - 14:23 EDT
This incident affected: Proficient Capture Web Application.