PH Exchange Log In Issues

Incident Report for Proficient Health

Resolved

PH Exchange Users,

Amazon Web Services has now resolved the issue affecting the eastern United States. We have completed our system checks and verified the PH Exchange system is fully operational.

If you continue to experience any issues within the application, please notify us at exchange@proficienthealth.com.

Thank you,
Proficient Health Support Team
Posted Dec 08, 2021 - 11:04 EST

Monitoring

PH Exchange users,

We are currently performing operations to recover from the Amazon Web Services outage yesterday and into last night, which may impact performance this morning.

The application should now be accessible, and we will provide another update once all functionality has been restored.

Sincerely,

Proficient Health Support
Posted Dec 08, 2021 - 09:31 EST

Identified

PH Exchange users,

Amazon Web Services is currently experiencing a widespread issue that is affecting the eastern United States and as a result PH Exchange may not be operational at this time.

We are diligently working with them to identify and resolve these issues, and will provide an update as soon as available.

Sincerely,
Proficient Health Support
Posted Dec 07, 2021 - 11:37 EST

Investigating

PH Exchange users,

An upstream carrier is currently having issues that is affecting user log ins to PH Exchange.

We are diligently working with them to identify and resolve these issues, and will provide an update once the cause has been identified or resolved.

Sincerely,

Proficient Health Support
Posted Dec 07, 2021 - 11:02 EST
This incident affected: Exchange Web Application.